We Can Help

How do I use LastPass on Mac 10.4?

Unfortunately we don't support Safari on Mac 10.4 with a LastPass plugin. However, you can use Firefox 3.5.x with LastPass, or you could install bookmarklets in Safari.

Still Having Trouble?
Look for answers in our vibrant customer-to-customer community help forums.


View your account information and view the status of previously submitted support tickets.


Submit a support ticket and we'll get back to you as soon as we can!

Safari

Enter a few words explaining what you need help with

Please type your question in English

Please review these answers to your question:

Still Having Trouble?
Look for answers in our vibrant customer-to-customer community help forums.


View your account information and view the status of previously submitted support tickets.


Submit a support ticket and we'll get back to you as soon as we can!


Browse through our FAQs:

Do you have any Heartbleed questions?