We Can Help

LastPass doesn't show up in Safari after upgrading to Lion 10.7 or running Software Update for Safari 5.1. How can I install the new version?

This package will uninstall all existing copies of LastPass and upgrade your computer to the latest version that works with Safari 5.1 : https://lastpass.com/lpsafari_EOL.pkg

This link will only work on a Mac and you will need administrative rights on the machine to run the installer. This software package supports Safari 5.1 on OSX 10.6 Snow Leopard and 10.7 Lion.

If you are on a PC and need to upgrade, you can simply do so by going to this URL in Safari : http://www.lastpass.com/dl 

Still Having Trouble?
Look for answers in our vibrant customer-to-customer community help forums.


View your account information and view the status of previously submitted support tickets.


Submit a support ticket and we'll get back to you as soon as we can!

Safari, Quick Start-up Guide, Account Recovery, Backup & Restore, Uninstalling

Enter a few words explaining what you need help with

Please type your question in English

Please review these answers to your question:

Still Having Trouble?
Look for answers in our vibrant customer-to-customer community help forums.


View your account information and view the status of previously submitted support tickets.


Submit a support ticket and we'll get back to you as soon as we can!


Browse through our FAQs:

Do you have any Heartbleed questions?